Upgrading iPad/iPhone to 7.1 – ‘Unable to locate DeviceSupport directory matched with connected device info’

Recently Apple released new version of the iOS for iPhone and iPad.

If you start Delphi XE5 and you will try to compile the application you will get error:

‘Unable to locate DeviceSupport directory matched with connected device info’

What you need to do is:

Step 1) to import the new iOS SDK.

At the Delphi go to Tools -> Options and Under Enviroment Options is the SDK Manager.

updateios

 

The new iPhoneOS 7.1 should be listed.

If you don’t have it, go to your Mac and update the Xcode via App Store.

When you click the OK button the actual SDK will get imported.

If you are using more libraries than are officially supported by Delphi, you need to copy the manually from your Mac.

At the windows they are located at:
C:\Users\<your user>\Documents\RAD Studio\SDKs\<version of the iOS SDK>\System\Library\Frameworks\.

At the Mac they are locates at: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/<version of the iOS SDK>/System/Library\Frameworks/ .

Just copy the files and everything will start to work.

Restart the Delphi and restart the Xcode at the Mac.

Step 2) If you still have the problem, then:

a) go to your mac and stat XCode

b) open Organized (Window -> Organizer)

c) Connect your device and check the device version:

Screen Shot 2014-03-14 at 13.48.50

You will see version (in my case it’s 7.1) and the version identification (in my case 11D167)

d) go to folder /Users/<your name>/Library/Developer/XCode/iOS DeviceSupport

e) There should be folder of your version and version identification – in my case it’s 7.1 (11d167). In my case there was folder 7.1 (11d169), but not 11d167. That’s because my iPhone 11d167, but the iPad Air 11d169. I think it’s a bug in Xcode Organizer that that the correct folder wasn’t created.

f) Just take any existing folder and copy it under correct name.

f) Disconnect the device and restart Xcode.

g) Reconnect the device and the you will see Organizer will start to import the DeviceSupport from your device.

And everything start to work!

 

10 comments

  1. Xander Harrison says:

    I don’t even have a 7.1 folder in the iOS DeviceSupport folder… Tried copying and renaming the 7.0.6 one but that didn’t work.

    • pjstrnad says:

      Did you started Organizer from Xcode?

      • Xander Harrison says:

        Yeah, Organizer is open and the iPhone is listed, with 7.1 (11D167) and even has the green circle to it. But still get that error when running from Delphi.

        • pjstrnad says:

          ok, and under /Users//Library/Developer/XCode/iOS DeviceSupport you have the device?

          if not, try to restart xcode or even Mac and unplug and plug the iPhone few times.

          • Xander Harrison says:

            No, that’s the problem.

            I have 6.0.1, 6.1.3, 6.1.6 and 7.0.6 in there, but no 7.1. Restarting the Mac or Xcode and plugging back in the phone make no differences 🙁

  2. pjstrnad says:

    And If you copy manually 7.0.6 to 7.1 ?

  3. Tamba says:

    I didn’t have the 7.1 folder, but I have 7.0.6 folder,I copied and rename to 7.1 and worked for me.
    I followed just d) and e) steps.

Leave a Reply to Xander Harrison Cancel reply

Your email address will not be published. Required fields are marked *